ironruby – Release: 1.1

ということで、1.1がリリースです。

Release Notes

IronRuby 1.1 is the first release after IronRuby 1.0, the first stable version of the Ruby 1.8.6 compiler for the .NET framework. IronRuby 1.1 is NOT fully backwards compatible with IronRuby 1.0; most notably that IronRuby 1.1 no longer supports .NET 2.0 SP1. .NET 3.5 is the minimum requirement for IronRuby 1.1, though using .NET 4.0 is strongly advised. Also, though this release is primarily bug-fixes for 1.0, consider any new features "Alpha" quality.

ironruby – Release: 1.1(ダウンロードもこちら。あれなんかWindows Phone 7とか書いてありますけど)

えっと。。。1.0に対する後方互換性はないからね(キリッ)みたいに言われてもぇ。各位ご検証のほどを。。。

そして今回の目玉が、Extension Methods(拡張メソッド)のサポートです。というか、これ実質Linq使いたいからだろ。

load_assembly "System.Core"
using_clr_extensions System::Linq
# …
products. where(lambda { |p| p.units_in_stock == 0 }). each { |x| puts x.product_name }

まぁこういう風に書けると。

1.0までの経緯であれだけRuby Specにこだわっていたのはいったい何だったんだろうかという梅雨明けの様なさわやかな展開に感涙が絶えません。

コメントを残す